const regex = /## \(#.*?\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('## \\(#.*?\\)', 'gm')
const str = `## (#compact)\`_.compact(array)\`
## (#concat)\`_.concat(array, [values])\``;
const subst = `## \{#.*?\}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);