$re = '/## \(#.*?\)/m';
$str = '## (#compact)`_.compact(array)`
## (#concat)`_.concat(array, [values])`';
$subst = "## \{#.*?\}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;