import Foundation
let pattern = ##"(#(?!thankyouburger)[\w]+)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
This guy makes my world turn and is my hero. He's #rescued. me from some of my darkest days and has been my champion through my struggles with combat related PTSD. I love you the mosterest, D1. 💚 #thankyouburger #dsdsfgd #sdfsdf #sdsfdfs, #sdffs
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"($1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)