const regex = /(#(?!thankyouburger)[\w]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(#(?!thankyouburger)[\\w]+)', 'g')
const str = `
This guy makes my world turn and is my hero. He's #rescued. me from some of my darkest days and has been my champion through my struggles with combat related PTSD. I love you the mosterest, D1. 💚 #thankyouburger #dsdsfgd #sdfsdf #sdsfdfs, #sdffs`;
const subst = `($1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);