using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#(?!thankyouburger)[\w]+)";
string substitution = @"($1)";
string input = @"
This guy makes my world turn and is my hero. He's #rescued. me from some of my darkest days and has been my champion through my struggles with combat related PTSD. I love you the mosterest, D1. 💚 #thankyouburger #dsdsfgd #sdfsdf #sdsfdfs, #sdffs";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}