# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(#(?!thankyouburger)[\w]+)/($1)/g;t' <<< "
This guy makes my world turn and is my hero. He's #rescued. me from some of my darkest days and has been my champion through my struggles with combat related PTSD. I love you the mosterest, D1. 💚 #thankyouburger #dsdsfgd #sdfsdf #sdsfdfs, #sdffs"