$re = '/(#(?!thankyouburger)[\w]+)/';
$str = '
This guy makes my world turn and is my hero. He\'s #rescued. me from some of my darkest days and has been my champion through my struggles with combat related PTSD. I love you the mosterest, D1. 💚 #thankyouburger #dsdsfgd #sdfsdf #sdsfdfs, #sdffs';
$subst = "($1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;