re = /<\/?[^\0- !-@[-`{-\x7f][^\0- !-,:-@[-`{-\x7f]*+(?!>)/m
str = '<div></div><input></input'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result