$re = '#</?[^\0- !-@[-`{-\x7f][^\0- !-,:-@[-`{-\x7f]*+(?!>)#m';
$str = '<div></div><input></input';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;