use strict;
my $str = '<div></div><input></input';
my $regex = qr#</?[^\0- !-@[-`{-\x7f][^\0- !-,:-@[-`{-\x7f]*+(?!>)#mp;
my $subst = '';
my $result = $str =~ s#$regex#$subst#rg;
print "The result of the substitution is' $result\n";