// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)window\.location\.href\s*=\s*\"([^\"]+)\""#).unwrap();
let string = "<html><meta charset=\"utf-8\" /><title>检测中</title><div>跳转中</div></html>
<script> window.location.href =\"/post/26784.html?btwaf=17282404\"; </script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}