package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)window\.location\.href\s*=\s*\"([^\"]+)\"`)
var str = `<html><meta charset="utf-8" /><title>检测中</title><div>跳转中</div></html>
<script> window.location.href ="/post/26784.html?btwaf=17282404"; </script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}