import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "window\\.location\\.href\\s*=\\s*\\\"([^\\\"]+)\\\"";
final String string = "<html><meta charset=\"utf-8\" /><title>检测中</title><div>跳转中</div></html>\n"
+ "<script> window.location.href =\"/post/26784.html?btwaf=17282404\"; </script>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}