$re = '/window\.location\.href\s*=\s*\"([^\"]+)\"/m';
$str = '<html><meta charset="utf-8" /><title>检测中</title><div>跳转中</div></html>
<script> window.location.href ="/post/26784.html?btwaf=17282404"; </script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);