#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)window\.location\.href\s*=\s*\"([^\"]+)\""
Local $sString = "<html><meta charset="utf-8" /><title>检测中</title><div>跳转中</div></html>" & @CRLF & _
"<script> window.location.href ="/post/26784.html?btwaf=17282404"; </script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")