re = /([\d][\d][\d]+)/m
str = '1213adfsdfad12131121sdfad12
1213adfsdfad12131121sdfad12
1213adfsdfad12131121sdfad1212adf
1213adfsdfad12131121sdfad12adfasdf12
1213adfsdfad12131121sdfad12431214345sdf12ad1212'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end