using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d][\d][\d]+)";
string input = @"1213adfsdfad12131121sdfad12
1213adfsdfad12131121sdfad12
1213adfsdfad12131121sdfad1212adf
1213adfsdfad12131121sdfad12adfasdf12
1213adfsdfad12131121sdfad12431214345sdf12ad1212";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}