#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\d][\d][\d]+)"
Local $sString = "1213adfsdfad12131121sdfad12" & @CRLF & _
"1213adfsdfad12131121sdfad12" & @CRLF & _
"1213adfsdfad12131121sdfad1212adf" & @CRLF & _
"1213adfsdfad12131121sdfad12adfasdf12" & @CRLF & _
"1213adfsdfad12131121sdfad12431214345sdf12ad1212"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")