const regex = new RegExp('([\\d][\\d][\\d]+)', 'gm')
const str = `1213adfsdfad12131121sdfad12
1213adfsdfad12131121sdfad12
1213adfsdfad12131121sdfad1212adf
1213adfsdfad12131121sdfad12adfasdf12
1213adfsdfad12131121sdfad12431214345sdf12ad1212`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}