package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\d][\d][\d]+)`)
var str = `1213adfsdfad12131121sdfad12
1213adfsdfad12131121sdfad12
1213adfsdfad12131121sdfad1212adf
1213adfsdfad12131121sdfad12adfasdf12
1213adfsdfad12131121sdfad12431214345sdf12ad1212`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}