re = /(^[a-z][a-z0-9._]+[a-z0-9]+$)/m
str = 'username123
USername12
user 12
user-1234name$
user.name.
.username12
1username
username4444
user123user
user.name
user_name
user asdsad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end