import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[a-z][a-z0-9._]+[a-z0-9]+$)";
final String string = "username123\n"
+ "USername12\n"
+ "user 12 \n"
+ "user-1234name$\n"
+ "user.name.\n"
+ ".username12\n"
+ "1username\n"
+ "username4444\n"
+ "user123user\n"
+ "user.name\n"
+ "user_name\n"
+ "user asdsad";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}