using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[a-z][a-z0-9._]+[a-z0-9]+$)";
string input = @"username123
USername12
user 12
user-1234name$
user.name.
.username12
1username
username4444
user123user
user.name
user_name
user asdsad";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}