#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[a-z][a-z0-9._]+[a-z0-9]+$)"
Local $sString = "username123" & @CRLF & _
"USername12" & @CRLF & _
"user 12 " & @CRLF & _
"user-1234name$" & @CRLF & _
"user.name." & @CRLF & _
".username12" & @CRLF & _
"1username" & @CRLF & _
"username4444" & @CRLF & _
"user123user" & @CRLF & _
"user.name" & @CRLF & _
"user_name" & @CRLF & _
"user asdsad"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")