$re = '/(^[a-z][a-z0-9._]+[a-z0-9]+$)/m';
$str = 'username123
USername12
user 12
user-1234name$
user.name.
.username12
1username
username4444
user123user
user.name
user_name
user asdsad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);