import Foundation
let pattern = #"^(\d{1,4})[\/|-|.\S](\d{1,2})[\/|-|.|\S](\d{1,4})[\T|\s](\d{1,2})[\:](\d{1,2})[\S|:](\d{2})?[\:|\s|.|Z]?(\d{7})?(?:AM)?(?:PM)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Validated
01.10.2008 17:04
10/1/2008 5:04 AM
01/10/2008 17:04
01.10.2008 17:04:32
10/1/2008 5:04:32 PM
2008-10-01T17:04:32.0000000
2008-10-01T17:04:32
2008-10-01 17:04:32Z
Not Works!
01.10.2008 17:04 '
10/1/2008 5:04 PM '
01/10/2008 17:04 '
01.10.2008 17:04:32 '
10/1/2008 5:04:32 PM '
2008-10-01T17:04:32.0000000 '
2008-10-01T17:04:32 '
2008-10-01 17:04:32Z '
Validate!
01.10.2008 17:04
10/1/2008 5:04 PM
01/10/2008 17:04
01.10.2008 17:04:32
10/1/2008 5:04:32 PM
2008-10-01T17:04:32.0000000
2008-10-01T17:04:32
2008-10-01 17:04:32Z
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)