re = /^(\d{1,4})[\/|-|.\S](\d{1,2})[\/|-|.|\S](\d{1,4})[\T|\s](\d{1,2})[\:](\d{1,2})[\S|:](\d{2})?[\:|\s|.|Z]?(\d{7})?(?:AM)?(?:PM)?$/m
str = 'Validated
01.10.2008 17:04
10/1/2008 5:04 AM
01/10/2008 17:04
01.10.2008 17:04:32
10/1/2008 5:04:32 PM
2008-10-01T17:04:32.0000000
2008-10-01T17:04:32
2008-10-01 17:04:32Z
Not Works!
01.10.2008 17:04 \'
10/1/2008 5:04 PM \'
01/10/2008 17:04 \'
01.10.2008 17:04:32 \'
10/1/2008 5:04:32 PM \'
2008-10-01T17:04:32.0000000 \'
2008-10-01T17:04:32 \'
2008-10-01 17:04:32Z \'
Validate!
01.10.2008 17:04
10/1/2008 5:04 PM
01/10/2008 17:04
01.10.2008 17:04:32
10/1/2008 5:04:32 PM
2008-10-01T17:04:32.0000000
2008-10-01T17:04:32
2008-10-01 17:04:32Z'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end