const regex = /^(\d{1,4})[\/|-|.\S](\d{1,2})[\/|-|.|\S](\d{1,4})[\T|\s](\d{1,2})[\:](\d{1,2})[\S|:](\d{2})?[\:|\s|.|Z]?(\d{7})?(?:AM)?(?:PM)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{1,4})[\\\/|-|.\\S](\\d{1,2})[\\\/|-|.|\\S](\\d{1,4})[\\T|\\s](\\d{1,2})[\\:](\\d{1,2})[\\S|:](\\d{2})?[\\:|\\s|.|Z]?(\\d{7})?(?:AM)?(?:PM)?$', 'gm')
const str = `Validated
01.10.2008 17:04
10/1/2008 5:04 AM
01/10/2008 17:04
01.10.2008 17:04:32
10/1/2008 5:04:32 PM
2008-10-01T17:04:32.0000000
2008-10-01T17:04:32
2008-10-01 17:04:32Z
Not Works!
01.10.2008 17:04 '
10/1/2008 5:04 PM '
01/10/2008 17:04 '
01.10.2008 17:04:32 '
10/1/2008 5:04:32 PM '
2008-10-01T17:04:32.0000000 '
2008-10-01T17:04:32 '
2008-10-01 17:04:32Z '
Validate!
01.10.2008 17:04
10/1/2008 5:04 PM
01/10/2008 17:04
01.10.2008 17:04:32
10/1/2008 5:04:32 PM
2008-10-01T17:04:32.0000000
2008-10-01T17:04:32
2008-10-01 17:04:32Z`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}