package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{1,4})[\/|-|.\S](\d{1,2})[\/|-|.|\S](\d{1,4})[\T|\s](\d{1,2})[\:](\d{1,2})[\S|:](\d{2})?[\:|\s|.|Z]?(\d{7})?(?:AM)?(?:PM)?$`)
var str = `Validated
01.10.2008 17:04
10/1/2008 5:04 AM
01/10/2008 17:04
01.10.2008 17:04:32
10/1/2008 5:04:32 PM
2008-10-01T17:04:32.0000000
2008-10-01T17:04:32
2008-10-01 17:04:32Z
Not Works!
01.10.2008 17:04 '
10/1/2008 5:04 PM '
01/10/2008 17:04 '
01.10.2008 17:04:32 '
10/1/2008 5:04:32 PM '
2008-10-01T17:04:32.0000000 '
2008-10-01T17:04:32 '
2008-10-01 17:04:32Z '
Validate!
01.10.2008 17:04
10/1/2008 5:04 PM
01/10/2008 17:04
01.10.2008 17:04:32
10/1/2008 5:04:32 PM
2008-10-01T17:04:32.0000000
2008-10-01T17:04:32
2008-10-01 17:04:32Z`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}