import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{1,4})[\\/|-|.\\S](\\d{1,2})[\\/|-|.|\\S](\\d{1,4})[\\T|\\s](\\d{1,2})[\\:](\\d{1,2})[\\S|:](\\d{2})?[\\:|\\s|.|Z]?(\\d{7})?(?:AM)?(?:PM)?$";
final String string = "Validated\n\n"
+ "01.10.2008 17:04\n"
+ "10/1/2008 5:04 AM\n"
+ "01/10/2008 17:04\n"
+ "01.10.2008 17:04:32\n"
+ "10/1/2008 5:04:32 PM\n\n"
+ "2008-10-01T17:04:32.0000000\n"
+ "2008-10-01T17:04:32\n"
+ "2008-10-01 17:04:32Z\n\n\n\n\n"
+ "Not Works!\n"
+ "01.10.2008 17:04 '\n"
+ "10/1/2008 5:04 PM '\n"
+ "01/10/2008 17:04 ' \n"
+ "01.10.2008 17:04:32 '\n"
+ "10/1/2008 5:04:32 PM '\n\n"
+ "2008-10-01T17:04:32.0000000 '\n"
+ "2008-10-01T17:04:32 ' \n"
+ "2008-10-01 17:04:32Z '\n\n"
+ "Validate!\n"
+ "01.10.2008 17:04\n\n"
+ "10/1/2008 5:04 PM\n"
+ "01/10/2008 17:04\n"
+ "01.10.2008 17:04:32\n"
+ "10/1/2008 5:04:32 PM\n\n"
+ "2008-10-01T17:04:32.0000000\n"
+ "2008-10-01T17:04:32\n"
+ "2008-10-01 17:04:32Z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}