$re = '/^outgoingaff\.txt|outgoingopsc2days\.txt|outgoingopsc6days\.txt$/m';
$str = 'outgoing.txt
outgoingaff.txt
outgoingopsc2days.txt
outgoingopsc6days.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);