import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^outgoingaff\\.txt|outgoingopsc2days\\.txt|outgoingopsc6days\\.txt$";
final String string = "outgoing.txt\n"
+ "outgoingaff.txt\n"
+ "outgoingopsc2days.txt\n"
+ "outgoingopsc6days.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}