using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^outgoingaff\.txt|outgoingopsc2days\.txt|outgoingopsc6days\.txt$";
string input = @"outgoing.txt
outgoingaff.txt
outgoingopsc2days.txt
outgoingopsc6days.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}