package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^outgoingaff\.txt|outgoingopsc2days\.txt|outgoingopsc6days\.txt$`)
var str = `outgoing.txt
outgoingaff.txt
outgoingopsc2days.txt
outgoingopsc6days.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}