#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^outgoingaff\.txt|outgoingopsc2days\.txt|outgoingopsc6days\.txt$"
Local $sString = "outgoing.txt" & @CRLF & _
"outgoingaff.txt" & @CRLF & _
"outgoingopsc2days.txt" & @CRLF & _
"outgoingopsc6days.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")