import Foundation
let pattern = #"^\([+|-]*((90|[1-8][0-9]|[0-9])|(([1-8][0-9]|[0-9])\.\d+)|90\.[0]+)\,\s[+|-]*((180|1[0-7][0-9]|[1-9][0-9]|[0-9])|((1[0-7][0-9]|[1-9][0-9]|[0-9])[\.]\d+)|180\.[0]+)\)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(-6, -165)
(-6.871826, -165.871826)
(-98, -40)
(-98.122626, -40.122626)
(-6, -172)
(-6.377934, -172.377934)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)