import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\([+|-]*((90|[1-8][0-9]|[0-9])|(([1-8][0-9]|[0-9])\\.\\d+)|90\\.[0]+)\\,\\s[+|-]*((180|1[0-7][0-9]|[1-9][0-9]|[0-9])|((1[0-7][0-9]|[1-9][0-9]|[0-9])[\\.]\\d+)|180\\.[0]+)\\)$";
final String string = "(-6, -165)\n"
+ "(-6.871826, -165.871826)\n"
+ "(-98, -40)\n"
+ "(-98.122626, -40.122626)\n"
+ "(-6, -172)\n"
+ "(-6.377934, -172.377934)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}