package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\([+|-]*((90|[1-8][0-9]|[0-9])|(([1-8][0-9]|[0-9])\.\d+)|90\.[0]+)\,\s[+|-]*((180|1[0-7][0-9]|[1-9][0-9]|[0-9])|((1[0-7][0-9]|[1-9][0-9]|[0-9])[\.]\d+)|180\.[0]+)\)$`)
var str = `(-6, -165)
(-6.871826, -165.871826)
(-98, -40)
(-98.122626, -40.122626)
(-6, -172)
(-6.377934, -172.377934)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}