use strict;
my $str = '(-6, -165)
(-6.871826, -165.871826)
(-98, -40)
(-98.122626, -40.122626)
(-6, -172)
(-6.377934, -172.377934)';
my $regex = qr/^\([+|-]*((90|[1-8][0-9]|[0-9])|(([1-8][0-9]|[0-9])\.\d+)|90\.[0]+)\,\s[+|-]*((180|1[0-7][0-9]|[1-9][0-9]|[0-9])|((1[0-7][0-9]|[1-9][0-9]|[0-9])[\.]\d+)|180\.[0]+)\)$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}