$re = '/^\([+|-]*((90|[1-8][0-9]|[0-9])|(([1-8][0-9]|[0-9])\.\d+)|90\.[0]+)\,\s[+|-]*((180|1[0-7][0-9]|[1-9][0-9]|[0-9])|((1[0-7][0-9]|[1-9][0-9]|[0-9])[\.]\d+)|180\.[0]+)\)$/';
$str = '(-6, -165)
(-6.871826, -165.871826)
(-98, -40)
(-98.122626, -40.122626)
(-6, -172)
(-6.377934, -172.377934)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);