import Foundation
let pattern = #"^t(\w*) (?:changelog|chlog|chglog) (\w*)(?:\(([\w\$\.\-\*\sа-яА-Я]*)\))?\:\s(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"t222 changelog add(Специалист): Добавлена какая-то херабора"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}