const regex = new RegExp('^t(\\w*) (?:changelog|chlog|chglog) (\\w*)(?:\\(([\\w\\$\\.\\-\\*\\sа-яА-Я]*)\\))?\\:\\s(.*)$', 'i')
const str = `t222 changelog add(Специалист): Добавлена какая-то херабора`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}