using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^t(\w*) (?:changelog|chlog|chglog) (\w*)(?:\(([\w\$\.\-\*\sа-яА-Я]*)\))?\:\s(.*)$";
string input = @"t222 changelog add(Специалист): Добавлена какая-то херабора";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}