re = /^t(\w*) (?:changelog|chlog|chglog) (\w*)(?:\(([\w\$\.\-\*\sа-яА-Я]*)\))?\:\s(.*)$/i
str = 't222 changelog add(Специалист): Добавлена какая-то херабора'
# Print the match result
str.match(re) do |match|
puts match.to_s
end