#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^t(\w*) (?:changelog|chlog|chglog) (\w*)(?:\(([\w\$\.\-\*\sа-яА-Я]*)\))?\:\s(.*)$"
Local $sString = "t222 changelog add(Специалист): Добавлена какая-то херабора"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")