re = /(?:(\S*)\s*{\s*(?:(\S*))\s*:\s*(?:([^"\s]*)|(".*"));\s*})+/m
str = 'div {
color: red;
}
span{color:blue;}
table#handsome {
font: "Comic Sans MS";
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end