$re = '/(?:(\S*)\s*{\s*(?:(\S*))\s*:\s*(?:([^"\s]*)|(".*"));\s*})+/m';
$str = 'div {
color: red;
}
span{color:blue;}
table#handsome {
font: "Comic Sans MS";
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);