using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\S*)\s*{\s*(?:(\S*))\s*:\s*(?:([^""\s]*)|("".*""));\s*})+";
string input = @"div {
color: red;
}
span{color:blue;}
table#handsome {
font: ""Comic Sans MS"";
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}