package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\S*)\s*{\s*(?:(\S*))\s*:\s*(?:([^"\s]*)|(".*"));\s*})+`)
var str = `div {
color: red;
}
span{color:blue;}
table#handsome {
font: "Comic Sans MS";
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}