import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\S*)\\s*\\{\\s*(?:(\\S*))\\s*:\\s*(?:([^\"\\s]*)|(\".*\"));\\s*\\})+";
final String string = "div {\n"
+ " color: red;\n"
+ "}\n\n"
+ "span{color:blue;}\n\n"
+ "table#handsome {\n"
+ " font: \"Comic Sans MS\";\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}